From: Zhang Yanfei <zhangyan...@cn.fujitsu.com>

This function is nowhere used, and it has a confusing name with
put_page in mm/swap.c. So better to remove it.

Signed-off-by: Zhang Yanfei <zhangyan...@cn.fujitsu.com>
---
 mm/internal.h |    5 -----
 1 files changed, 0 insertions(+), 5 deletions(-)

diff --git a/mm/internal.h b/mm/internal.h
index 8562de0..4390ac6 100644
--- a/mm/internal.h
+++ b/mm/internal.h
@@ -32,11 +32,6 @@ static inline void set_page_refcounted(struct page *page)
        set_page_count(page, 1);
 }
 
-static inline void __put_page(struct page *page)
-{
-       atomic_dec(&page->_count);
-}
-
 static inline void __get_page_tail_foll(struct page *page,
                                        bool get_page_head)
 {
-- 
1.7.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to