On Fri, 14 Feb 2014, Christoph Lameter wrote: > > @@ -215,9 +215,9 @@ static inline void set_obj_pfmemalloc(void **objp) > > return; > > } > > > > -static inline void clear_obj_pfmemalloc(void **objp) > > +static inline void *clear_obj_pfmemalloc(void *objp) > > { > > - *objp = (void *)((unsigned long)*objp & ~SLAB_OBJ_PFMEMALLOC); > > + return (void *)((unsigned long)objp & ~SLAB_OBJ_PFMEMALLOC); > > } > > I dont think you need the (void *) cast here. >
Yeah, you don't need it, but don't you think it makes the code more readable? Otherwise this is going to be just doing return (unsigned long)objp & ~SLAB_OBJ_PFMEMALLOC; and you gotta figure out the function type to understand it's returned as a pointer. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/