On 03/12/2014 11:06 AM, Antoine Ténart wrote:
Signed-off-by: Antoine Ténart <antoine.ten...@free-electrons.com>
---
  arch/arm/boot/dts/Makefile         |  3 ++-
  arch/arm/boot/dts/berlin2q-dmp.dts | 32 ++++++++++++++++++++++++++++++++
  2 files changed, 34 insertions(+), 1 deletion(-)
  create mode 100644 arch/arm/boot/dts/berlin2q-dmp.dts

diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
index 032030361bef..1a2adadfb962 100644
--- a/arch/arm/boot/dts/Makefile
+++ b/arch/arm/boot/dts/Makefile
@@ -52,7 +52,8 @@ dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm11351-brt.dtb \
  dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
  dtb-$(CONFIG_ARCH_BERLIN) += \
        berlin2-sony-nsz-gs7.dtb        \
-       berlin2cd-google-chromecast.dtb
+       berlin2cd-google-chromecast.dtb \
+       berlin2q-dmp.dtb

If it is "the" Marvell reference board, the file should be named
berlin2q-marvell-dmp.dtb.

  dtb-$(CONFIG_ARCH_DAVINCI) += da850-enbw-cmc.dtb \
        da850-evm.dtb
  dtb-$(CONFIG_ARCH_DOVE) += dove-cm-a510.dtb \
diff --git a/arch/arm/boot/dts/berlin2q-dmp.dts 
b/arch/arm/boot/dts/berlin2q-dmp.dts
new file mode 100644
index 000000000000..6a98860e0251
--- /dev/null
+++ b/arch/arm/boot/dts/berlin2q-dmp.dts
@@ -0,0 +1,32 @@
+/*
+ * Copyright (C) 2014 Antoine Ténart <antoine.ten...@free-electrons.com>
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2. This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+/dts-v1/;
+#include "berlin2q.dtsi"
+
+/ {
+       model = "Marvell BG2-Q DMP";
+       compatible = "marvell,berlin2q-dmp", "marvell,berlin2q", 
"marvell,berlin";
+
+       memory {
+               device_type = "memory";
+               reg = <0x00000000 0x40000000>;

Please double-check Jisheng's comment about memory size.

+       };
+
+       choosen {
+               bootargs = "console=ttyS0,115200 earlyprintk";
+       };
+
+       soc {
+               apb@fc0000 {
+                       uart0: uart@9000 {
+                               status = "okay";
+                       };
+               };
+       };

And Arnd's comment about using &uart0 instead.

Beside the comments made, this all looks fine.

Sebastian

+};


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to