>>>>> "Greg" == Greg KH <[EMAIL PROTECTED]> writes:

Greg> On Fri, Mar 11, 2005 at 02:37:17PM +1100, Peter Chubb wrote:
>> +/* + * The PCI subsystem is implemented as yet-another pseudo
>> filesystem, + * albeit one that is never mounted.  + * This is its
>> magic number.  + */ +#define USR_PCI_MAGIC (0x12345678)

Greg> If you make it a real, mountable filesystem, then you don't need
Greg> to have any of your new syscalls, right?  Why not just do that
Greg> instead?


The only call that would go is usr_pci_open() -- you'd still need 
usr_pci_map(), usr_pci_unmap() and usr_pci_get_consistent().

--
Dr Peter Chubb  http://www.gelato.unsw.edu.au  peterc AT gelato.unsw.edu.au
The technical we do immediately,  the political takes *forever*

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to