On Wed, Sep 17, 2014 at 12:43 AM, Paolo Bonzini <pbonz...@redhat.com> wrote: > Il 16/09/2014 20:42, Andres Lagar-Cavilla ha scritto: >> On Tue, Sep 16, 2014 at 11:29 AM, Paolo Bonzini <pbonz...@redhat.com> wrote: >>>> I think a first patch should introduce kvm_get_user_page_retry ("Retry >>>> a >>>> fault after a gup with FOLL_NOWAIT.") and the second would add >>>> FOLL_TRIED ("This properly relinquishes mmap semaphore if the >>>> filemap/swap has to wait on page lock (and retries the gup to >>>> completion >>>> after that"). >>>> >>>> That's not what FOLL_TRIED does. The relinquishing of mmap semaphore is >>>> done by this patch minus the FOLL_TRIED bits. FOLL_TRIED will let the >>>> fault handler (e.g. filemap) know that we've been there and waited on >>>> the IO already, so in the common case we won't need to redo the IO. >>> >>> Yes, that's not what FOLL_TRIED does. But it's the difference between >>> get_user_pages and kvm_get_user_page_retry, right? >> >> Unfortunately get_user_pages does not expose the param (int >> *nonblocking) that __gup will use to set FAULT_FLAG_ALLOW_RETRY. So >> that's one difference. The second difference is that kvm_gup_retry >> will call two times if necessary (the second without _RETRY but with >> _TRIED). > > Yeah, that's how it is in your patch. I can see that. > > What I'm saying is that your patch is two changes in one: > > 1) do not use gup_fast in hva_to_pfn_slow, instead use gup as in > async_pf_execute. This change can already introduce a function called > kvm_get_user_page_retry, and can already use it in async_pf_execute and > hva_to_pfn_slow > > 2) introduce the two-phase RETRY + TRIED mechanism in > kvm_get_user_page_retry, so that the mmap semaphore is relinquished > properly if the filemap or swap has to wait on the page lock. > > I would prefer to split it in two patches. Is it clearer now?
Understood. So in patch 1, would kvm_gup_retry be ... just a wrapper around gup? That looks thin to me, and the naming of the function will not be accurate. Plus, considering Radim's suggestion that the naming is not optimal. I can have patch 1 just s/gup_fast/gup (one liner), and then patch 2 do the rest of the work. Andres > > Paolo -- Andres Lagar-Cavilla | Google Kernel Team | andre...@google.com -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/