"sl->family->fops" and "fops" are the same thing, but it's nicer to use
"fops" everywhere.

Signed-off-by: Dan Carpenter <dan.carpen...@oracle.com>

diff --git a/drivers/w1/w1.c b/drivers/w1/w1.c
index 181f41c..59f932f 100644
--- a/drivers/w1/w1.c
+++ b/drivers/w1/w1.c
@@ -649,7 +649,7 @@ static int w1_family_notify(unsigned long action, struct 
w1_slave *sl)
                break;
        case BUS_NOTIFY_DEL_DEVICE:
                if (fops->remove_slave)
-                       sl->family->fops->remove_slave(sl);
+                       fops->remove_slave(sl);
                if (fops->groups)
                        sysfs_remove_groups(&sl->dev.kobj, fops->groups);
                break;
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to