linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH v4 0/4] rv/reactors: fix lockdep warning and add KUnit tests
wen . yang
[PATCH v4 4/4] rv/reactors: add KUnit tests for reactor registration and dispatch
wen . yang
Re: [PATCH v4 4/4] rv/reactors: add KUnit tests for reactor registration and dispatch
sashiko-bot
[PATCH v4 3/4] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
wen . yang
Re: [PATCH v4 3/4] rv/reactors: export rv_register_reactor() and rv_unregister_reactor()
sashiko-bot
[PATCH v4 2/4] rv/reactors: propagate rv_register_reactor() error from reactor init
wen . yang
[PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
wen . yang
Re: [PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
sashiko-bot
Re: [PATCH v4 1/4] rv/reactors: use LD_WAIT_SPIN as the reactor lockdep wait type
Gabriele Monaco
[RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Tobias Schaffner
[RFC 2/3] rv: add per-monitor edge-stat facility and stats file
Tobias Schaffner
Re: [RFC 2/3] rv: add per-monitor edge-stat facility and stats file
sashiko-bot
Re: [RFC 2/3] rv: add per-monitor edge-stat facility and stats file
Gabriele Monaco
[RFC 1/3] rv: add per-edge dwell-time statistics primitive
Tobias Schaffner
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
sashiko-bot
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Gabriele Monaco
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Tobias Schaffner
Re: [RFC 1/3] rv: add per-edge dwell-time statistics primitive
Gabriele Monaco
[RFC 3/3] rv: collect per-edge dwell time for per-cpu DA/HA monitors
Tobias Schaffner
Re: [RFC 3/3] rv: collect per-edge dwell time for per-cpu DA/HA monitors
sashiko-bot
Re: [RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Gabriele Monaco
Re: [RFC 0/3] rv: per-edge dwell-time statistics for per-cpu monitors
Tobias Schaffner
[PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH v2] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH v5 7/7] selftests/livepatch: Add RISC-V syscall wrapper prefix
Miroslav Benes
[PATCH v8 0/3] ring-buffer: Fixes for subbuf resizing and persistent buffers
Vincent Donnefort
[PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
sashiko-bot
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Vincent Donnefort
Re: [PATCH v8 1/3] tracing: Fix subbuf resize races with trace_pipe_raw readers
Steven Rostedt
[PATCH v8 2/3] ring-buffer: Cap static ring buffer nr_pages
Vincent Donnefort
[PATCH v8 3/3] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
Vincent Donnefort
Re: [PATCH v8 3/3] ring-buffer: Prevent truncation of nr_pages / nr_subbufs
sashiko-bot
[PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
[PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
sashiko-bot
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Bradley Morgan
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg KH
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Steven Rostedt
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Bradley Morgan
Re: [PATCH 2/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Johan Hovold
[PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
sashiko-bot
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Aaron Tomlin
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Johan Hovold
Re: [PATCH 1/2] module: pull out add_taint_module() to be public
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Greg Kroah-Hartman
Re: [PATCH 0/2] driver core: add TAINT_FORCED_BIND for when userspace manually messes with devices and drivers
Michal Pecio
[PATCH v11 00/46] guest_memfd: In-place conversion support
Ackerley Tng
[PATCH v11 03/46] KVM: guest_memfd: Introduce per-gmem attributes, use to guard user mappings
Ackerley Tng
[PATCH v11 08/46] KVM: Provide generic interface for checking memory private/shared status
Ackerley Tng
[PATCH v11 07/46] KVM: Rename kvm_mem_is_private() to kvm_is_private_gfn()
Ackerley Tng
[PATCH v11 09/46] KVM: guest_memfd: Stub in ability to enable in-place shared<=>private conversion
Ackerley Tng
[PATCH v11 01/46] KVM: guest_memfd: Optimize away conversion overheads via dead-code elimination
Ackerley Tng
[PATCH v11 12/46] KVM: guest_memfd: Pass mapping type filter to invalidation helper
Ackerley Tng
[PATCH v11 02/46] KVM: guest_memfd: Use kvm_mem_is_private() when populating guest_memfd memory
Ackerley Tng
[PATCH v11 04/46] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
Ackerley Tng
[PATCH v11 05/46] KVM: Enumerate support for PRIVATE memory iff kvm_arch_has_private_mem is defined
Ackerley Tng
[PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Ackerley Tng
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Michael Roth
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Michael Roth
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Ackerley Tng
Re: [PATCH v11 15/46] KVM: guest_memfd: Call arch make_shared callback for to-shared conversion
Sean Christopherson
[PATCH v11 06/46] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
Ackerley Tng
[PATCH v11 16/46] KVM: guest_memfd: Return early if range already has requested attributes
Ackerley Tng
[PATCH v11 11/46] KVM: guest_memfd: Invalidate both SHARED and PRIVATE mappings for in-place conversions
Ackerley Tng
[PATCH v11 14/46] KVM: guest_memfd: Ensure pages are not in use before conversion
Ackerley Tng
[PATCH v11 13/46] KVM: guest_memfd: Add base support for KVM_SET_MEMORY_ATTRIBUTES2
Ackerley Tng
[PATCH v11 18/46] KVM: guest_memfd: Handle lru_add fbatch refcounts during conversion safety check
Ackerley Tng
[PATCH v11 20/46] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Ackerley Tng
[PATCH v11 27/46] KVM: selftests: Add support for mmap() on guest_memfd in core library
Ackerley Tng
[PATCH v11 25/46] KVM: selftests: Create gmem fd before "regular" fd when adding memslot
Ackerley Tng
[PATCH v11 29/46] KVM: selftests: Add helpers for calling ioctls on guest_memfd
Ackerley Tng
[PATCH v11 28/46] KVM: selftests: Add selftests global for guest memory attributes capability
Ackerley Tng
[PATCH v11 30/46] KVM: selftests: Test basic single-page conversion flow
Ackerley Tng
[PATCH v11 39/46] KVM: selftests: Reset shared memory after hole-punching
Ackerley Tng
[PATCH v11 42/46] KVM: selftests: Make TEST_EXPECT_SIGBUS thread-safe
Ackerley Tng
[PATCH v11 41/46] KVM: selftests: Provide common function to set memory attributes
Ackerley Tng
[PATCH v11 22/46] KVM: Move KVM_VM_MEMORY_ATTRIBUTES config definition to x86
Ackerley Tng
[PATCH v11 31/46] KVM: selftests: Test conversion flow when INIT_SHARED
Ackerley Tng
[PATCH v11 38/46] KVM: selftests: Test conversion with elevated page refcount
Ackerley Tng
[PATCH v11 33/46] KVM: selftests: Test conversion before allocation
Ackerley Tng
[PATCH v11 36/46] KVM: selftests: Test that shared/private status is consistent across processes
Ackerley Tng
[PATCH v11 37/46] KVM: selftests: Add helpers to pin pages with CONFIG_GUP_TEST
Ackerley Tng
[PATCH v11 46/46] KVM: selftests: Update private memory exits test to work with per-gmem attributes
Ackerley Tng
[PATCH v11 43/46] KVM: selftests: Support guest_memfd attributes in private_mem_conversions_test
Ackerley Tng
[PATCH v11 44/46] KVM: selftests: Set up page size and alignment independently for guest_memfd
Ackerley Tng
[PATCH v11 45/46] KVM: selftests: Test in-place conversions in private_mem_conversions_test
Ackerley Tng
[PATCH v11 10/46] KVM: Consolidate private memory and guest_memfd ifdeffery in kvm_host.h
Ackerley Tng
[PATCH v11 17/46] mm/gup: factor out LRU cache draining for folio into lru_cache_drain_for_folio()
Ackerley Tng
[PATCH v11 19/46] KVM: guest_memfd: Zero page while getting pfn
Ackerley Tng
[PATCH v11 21/46] KVM: TDX: Make source page optional for KVM_TDX_INIT_MEM_REGION
Ackerley Tng
[PATCH v11 23/46] KVM: Let userspace disable per-VM mem attributes, enable per-gmem attributes
Ackerley Tng
[PATCH v11 24/46] KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs
Ackerley Tng
[PATCH v11 26/46] KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
Ackerley Tng
[PATCH v11 34/46] KVM: selftests: Convert with allocated folios in different layouts
Ackerley Tng
[PATCH v11 32/46] KVM: selftests: Test conversion precision in guest_memfd
Ackerley Tng
[PATCH v11 35/46] KVM: selftests: Test that truncation does not change shared/private status
Ackerley Tng
[PATCH v11 40/46] KVM: selftests: Provide function to look up guest_memfd details from gpa
Ackerley Tng
[PATCH v2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-multi-modify
Haotian Zhang
Re: [PATCH v2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-multi-modify
sashiko-bot
[PATCH v2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-modify
Haotian Zhang
Re: [PATCH v2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-modify
sashiko-bot
[PATCH] ftrace: Have stacktrace option work with func-args
Steven Rostedt
[PATCH] eventfs: Initialise ei->children before it can be freed
David Carlier
Re: [PATCH] eventfs: Initialise ei->children before it can be freed
Steven Rostedt
Re: [PATCH] eventfs: Initialise ei->children before it can be freed
David CARLIER
[RFC] tracing: aggregate ring-buffer memory statistics
Xiang Gao
Re: [RFC] tracing: aggregate ring-buffer memory statistics
Steven Rostedt
Re: [External Mail]Re: [RFC] tracing: aggregate ring-buffer memory statistics
Steven Rostedt
Re: [External Mail]Re: [RFC] tracing: aggregate ring-buffer memory statistics
Steven Rostedt
Re: [External Mail]Re: [RFC] tracing: aggregate ring-buffer memory statistics
Steven Rostedt
Re: [External Mail][RFC] tracing: aggregate ring-buffer memory statistics
Steven Rostedt
[PATCH v2 0/2] tracing: Fix remote reader page swap failures
Ivan Immanuel Shaji via B4 Relay
[PATCH v2 1/2] tracing: Fix retry exhaustion in simple ring buffer reader swap
Ivan Immanuel Shaji via B4 Relay
[PATCH v2 2/2] ring-buffer: Stop remote reader update when page swap fails
Ivan Immanuel Shaji via B4 Relay
[PATCH 0/2] ftrace/selftests: Fix registering kprobe on non-unique symbol
Alexander Gordeev
[PATCH 1/2] ftrace/selftests: Fix regex pattern to match vmlinux symbol names only
Alexander Gordeev
[PATCH 2/2] ftrace/selftests: Change non-unique test symbol to init_once
Alexander Gordeev
Re: [PATCH 0/2] ftrace/selftests: Fix registering kprobe on non-unique symbol
Alexander Gordeev
[GIT PULL] rv fixes for v7.3-rc1
Gabriele Monaco
[PATCH 2/2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-modify
Haotian Zhang
Re: [PATCH 2/2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-modify
Steven Rostedt
[PATCH 1/2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-multi-modify
Haotian Zhang
Re: [PATCH 1/2] samples/ftrace: Fix kthread_stop() on ERR_PTR in ftrace-direct-multi-modify
Steven Rostedt
[PATCH 0/2] tracing: Fix remote reader page swap failures
Ivan Immanuel Shaji via B4 Relay
[PATCH 2/2] ring-buffer: Stop remote reader update when page swap fails
Ivan Immanuel Shaji via B4 Relay
Re: [PATCH 2/2] ring-buffer: Stop remote reader update when page swap fails
sashiko-bot
Re: [PATCH 2/2] ring-buffer: Stop remote reader update when page swap fails
Vincent Donnefort
[PATCH 1/2] tracing: Fix retry exhaustion in simple ring buffer reader swap
Ivan Immanuel Shaji via B4 Relay
Re: [PATCH 1/2] tracing: Fix retry exhaustion in simple ring buffer reader swap
Vincent Donnefort
[PATCH 0/4] tracing/osnoise: Synchronization fixes
Crystal Wood
[PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Crystal Wood
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
sashiko-bot
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Steven Rostedt
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Crystal Wood
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Steven Rostedt
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Tomas Glozar
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Crystal Wood
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Tomas Glozar
Re: [PATCH 1/4] tracing/osnoise: Per-cpu mutex and fd detachment
Crystal Wood
[PATCH 2/4] tracing/osnoise: timerlat_main: Disable migration before per-cpu access
Crystal Wood
Re: [PATCH 2/4] tracing/osnoise: timerlat_main: Disable migration before per-cpu access
sashiko-bot
[PATCH 4/4] tracing/osnoise: Take trace_types_lock in timerlat_fd_open
Crystal Wood
Re: [PATCH 4/4] tracing/osnoise: Take trace_types_lock in timerlat_fd_open
sashiko-bot
[PATCH 3/4] tracing/osnoise: start_kthread: Always check OSN_WORKLOAD
Crystal Wood
[PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
Re: [PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Jérémy Jean
Re: [PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Steven Rostedt
Re: [PATCH] tracing/user_events: Clear copied tracing state before fork duplication
Bradley Morgan
[PATCH] tracing/user_events: Don't destroy fields when event removal fails
Henry Martin
Re: [PATCH] tracing/user_events: Don't destroy fields when event removal fails
Steven Rostedt
Re: [PATCH] tracing/user_events: Don't destroy fields when event removal fails
Beau Belgrave
[PATCH v2] tracing/user_events: Don't destroy fields when event removal fails
Henry Martin
Re: [PATCH v2] tracing/user_events: Don't destroy fields when event removal fails
sashiko-bot
Re: [PATCH v2] tracing/user_events: Don't destroy fields when event removal fails
Beau Belgrave
[PATCH] eventfs: Initialize ei->children and ei->list in init_ei()
Deepanshu Kartikey
Re: [PATCH] eventfs: Initialize ei->children and ei->list in init_ei()
Steven Rostedt
Re: [PATCH] eventfs: Initialize ei->children and ei->list in init_ei()
Deepanshu Kartikey
Re: [PATCH] eventfs: Initialize ei->children and ei->list in init_ei()
Steven Rostedt
Re: [RFC PATCH bpf-next v3 2/2] selftests/livepatch: update test-ftrace.sh for deprecated ftrace_enabled
Miroslav Benes
Re: [RFC PATCH bpf-next v3 2/2] selftests/livepatch: update test-ftrace.sh for deprecated ftrace_enabled
Miroslav Benes
Re: [RFC PATCH bpf-next v3 2/2] selftests/livepatch: update test-ftrace.sh for deprecated ftrace_enabled
Petr Mladek
Re: [RFC PATCH bpf-next v3 1/2] ftrace: deprecate disabling via ftrace_enabled sysctl
Miroslav Benes
Re: [RFC PATCH bpf-next v3 1/2] ftrace: deprecate disabling via ftrace_enabled sysctl
Miroslav Benes
[PATCH v2] tracing: Fix use-after-free on field name/type of dynamic probe events
Henry Martin
Re: [PATCH v2] tracing: Fix use-after-free on field name/type of dynamic probe events
sashiko-bot
[syzbot] [fs?] [trace?] WARNING in eventfs_create_events_dir
syzbot
Re: [syzbot] [fs?] [trace?] WARNING in eventfs_create_events_dir
syzbot
Re: [syzbot] [fs?] [trace?] WARNING in eventfs_create_events_dir
Steven Rostedt
Earlier messages
Later messages