On Mon, Oct 27, 2014 at 09:11:27PM -0700, Paul E. McKenney wrote: > On Tue, Oct 28, 2014 at 01:12:14AM +0000, Al Viro wrote: > > On Mon, Oct 27, 2014 at 10:36:21AM -0700, Paul E. McKenney wrote: > > > Code making direct use of smp_read_barrier_depends() is harder to read, > > > in my experience, but good point on the sparse noise. Maybe a new > > > lockless_dereference() primitive? Maybe something like the following? > > > (Untested, probably does not even build.) > > > > > > #define lockless_dereference(p) \ > > > ({ \ > > > typeof(*p) *_________p1 = ACCESS_ONCE(p); \ > > > smp_read_barrier_depends(); /* Dependency order vs. p above. */ \ > > > _________p1; \ > > > }) > > > > Hmm... Where would you prefer to put it? rcupdate.h? > > Good a place as any, I guess. Please see patch below. Left to myself, > I would send this along for the next merge window, but please let me > know if you would like it sooner.
It's needed sooner, unfortunately. Guys, could you take a look at vfs.git#for-linus and comment? -- To unsubscribe from this list: send the line "unsubscribe linux-unionfs" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html