Here is what happens when one I  boot  a RH9 IBM xseries box.

EXT3-fs: mounted filesystem with ordered data mode.
Freeing unused kernel mamory: 132k freed
INIT: version 2.84 booting
Settomg defai;t fpmt (latarcyrheb-sun16): [ ok ]
Welcome to /etc/rc.d/rc.synsinit: line 70: 35 Segmentation fault LC_ALL=C grep
-q "Red Hat" /etc/redhat-release Red Hat Linux
Press 'I' to enter interactive startup.
Mounting proc filesystem: [failed]
/etc/rc.d/rc.sysinit: line 90: 42 Segmantation fault LC_ALL=C grep -q .initrd
/proc/mounts
Confuguring kernel parameters: Error: /proc must ve mounted
To mount /proc at boot you need an /etcfstab line like:
/proc /proc proc defaults
In the meantime, mount /proc /proc -t proc
[failed]
Setting clock (localtime): Fi Jan 23 09:06:35 MST 2004 [ ok ]
Loading default keymap (us): [ ok ]
Setting hosname mgserver.net: [ ok ]
/etc/rc,d/rc.sysinit: line 182: 65 Segmentation fault LC-ALL=C grep -iq"nousb"

I know RH9 is old, but lets not debate on that for now. Checked all
hardware, raid, disks, even replaced RAM. So not a hardware issue.
Gives same error while booting to single user mode too. Able to boot
to rescue mode. Examined fstab. Has proper proc line. Grub is set up
fine too, Did nothing special to trigger the error. Was getting
segfaults with grep, rebooted, got stuck.

Consulted lots of experts, google, RH kbase. No go. Perhaps you
mortals can save us a reinstall? Why on earth won't proc mount?

Regards,
NMK.

--
http://mm.glug-bom.org/mailman/listinfo/linuxers

Reply via email to