> libfdt is supposed to easy to embed in projects all and sundry.
> Often, it won't be practical to separate the embedded libfdt's
> namespace from that of the surrounding project.  Which means there can
> be namespace conflicts between even libfdt's internal/static functions
> and functions or macros coming from the surrounding project's headers
> via libfdt_env.h.
> 
> This patch, therefore, renames a bunch of libfdt internal functions
> and macros and makes a few other chances to reduce the chances of
> namespace collisions with embedding projects.  Specifically:
>       - Internal functions (even static ones) are now named _fdt_*()
> 
>       - The type and (static) global for the error table in
>           fdt_strerror() gain an fdt_ prefix
> 
>       - The unused macro PALIGN is removed
> 
>       - The memeq and streq macros are removed and open-coded in the
>           users (they were only used once each)
> 
>       - Other macros gain an FDT_ prefix
> 
>       - To save some of the bulk from the previous change, an
>           FDT_TAGALIGN() macro is introduced, where FDT_TAGALIGN(x) ==
>           FDT_ALIGN(x, FDT_TAGSIZE)
> 
> Signed-off-by: David Gibson <[EMAIL PROTECTED]>

Applied.

jdl
_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev

Reply via email to