On 21/09/2026 7:36 am, Aneesh Kumar K.V (Arm) wrote:
A default SWIOTLB pool used only for unaligned kmalloc bouncing can be
smaller than one required for limited DMA addressing. Arm64 and RISC-V
currently implement this sizing independently, using 1 MiB of SWIOTLB
space per GiB of RAM.
The SWIOTLB core now identifies this case with SWIOTLB_POOL_MINIMAL.
Size that policy in swiotlb_adjust_pool_size() and remove the
architecture-specific adjustments.
Explicit swiotlb= sizing remains unchanged because swiotlb_adjust_size()
preserves a user-configured size.
Signed-off-by: Aneesh Kumar K.V (Arm) <[email protected]>
---
arch/arm64/mm/init.c | 11 -----------
arch/riscv/mm/init.c | 4 ----
kernel/dma/swiotlb.c | 11 ++++++++++-
3 files changed, 10 insertions(+), 16 deletions(-)
diff --git a/arch/arm64/mm/init.c b/arch/arm64/mm/init.c
index 7d51fb5f5a71..95075b5c8207 100644
--- a/arch/arm64/mm/init.c
+++ b/arch/arm64/mm/init.c
@@ -340,17 +340,6 @@ void __init arch_mm_preinit(void)
{
unsigned int flags = SWIOTLB_VERBOSE;
- if (max_pfn <= PFN_DOWN(arm64_dma_phys_limit)) {
- /*
- * If no bouncing needed for ZONE_DMA, reduce the swiotlb
- * buffer for kmalloc() bouncing to 1MB per 1GB of RAM.
- */
- unsigned long size =
- DIV_ROUND_UP(memblock_phys_mem_size(), 1024);
-
- swiotlb_adjust_size(min(swiotlb_size_or_default(), size));
- }
-
if (max_pfn > PFN_DOWN(arm64_dma_phys_limit))
flags |= SWIOTLB_INIT_ADDRESSING_LIMIT;
diff --git a/arch/riscv/mm/init.c b/arch/riscv/mm/init.c
index e0e4c103d603..96856114b387 100644
--- a/arch/riscv/mm/init.c
+++ b/arch/riscv/mm/init.c
@@ -183,10 +183,6 @@ void __init arch_mm_preinit(void)
* memory when DRAM starts above dma32_phys_limit. Allocate
* ~1 MB per 1 GB of RAM.
*/
- unsigned long size =
- DIV_ROUND_UP(memblock_phys_mem_size(), 1024);
- swiotlb_adjust_size(min(swiotlb_size_or_default(), size));
- swiotlb = true;
swiotlb_flags |= SWIOTLB_ANY;
}
diff --git a/kernel/dma/swiotlb.c b/kernel/dma/swiotlb.c
index 8f86deb25be2..f368a73f4ed0 100644
--- a/kernel/dma/swiotlb.c
+++ b/kernel/dma/swiotlb.c
@@ -483,9 +483,18 @@ static bool __init swiotlb_kmalloc_needs_bounce(void)
static void __init
swiotlb_adjust_pool_size(enum swiotlb_pool_policy policy)
{
+ if (swiotlb_default_size_changed())
+ return;
+
This appears to be entirely redundant, as ultimately the point of this
function is to call swiotlb_adjust_size() (if it does anything at all),
and the first thing that does is this same exact check. We hardly need
to micro-optimise short-circuiting a handful of arithmetic in a one-off
setup path, and it's convoluted enough as it is, so please try to avoid
redundancy that makes it even more confusing to follow.
switch (policy) {
- case SWIOTLB_POOL_MINIMAL:
+ case SWIOTLB_POOL_MINIMAL: {
+ unsigned long size;
+
+ /* Use 1MB per 1GB of RAM for kmalloc() bouncing. */
+ size = DIV_ROUND_UP(memblock_phys_mem_size(), 1024);
+ swiotlb_adjust_size(min(swiotlb_size_or_default(), size));
break;
Similarly I think it would be clearer if we had a common
swiotlb_adjust_size() call at the end of the function, and then either
calculate a size or return early in each switch case as appropriate.
Furthermore, swiotlb_size_or_default() is awful IMO - and in fact after
this series we could perhaps clean it up entirely by making the size
implicit in swiotlb_init_late() - not to mention misleadingly redundant.
I'd say just open-code "default_nslabs << IO_TLB_SHIFT" like elsewhere
in the file, but in fact it may as well just be IO_TLB_DEFAULT_SIZE
(think about it...)
Thanks,
Robin.
+ }
case SWIOTLB_POOL_CC_GUEST:
break;
case SWIOTLB_POOL_NONE: