> > +   /* Workaround for data length mismatch errata */
> > +   if (unlikely(hstatus & INT_ON_DATA_LENGTH_MISMATCH)) {
> > +           for (tag = 0; tag < ATA_MAX_QUEUE; tag++) {
> > +                   qc = ata_qc_from_tag(ap, tag);
> > +                   if (qc && ata_is_atapi(qc->tf.protocol)) {
> > +                           u32 hcontrol;
> > +#define HCONTROL_CLEAR_ERROR       (1 << 27)
> 
> shouldn't we have this #define be part of the enum that the other
> HCONTROL_ bits/flags are part of?
[S.H] do you mean this?

#ifdef SATA_FSL_XXX_ERRATUAM
#define HCONTROL_CLEAR_ERROR    (1 << 27)
#endif

Then we need to decide where to put "#define SATA_FSL_XXX_ERRATUAM".

It's only a readable definition of a register bit which avoiding magic number.


Best Regards, 
Shaohui Xie

_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Reply via email to