Probably should be renamed since it did get annoying when both were in scope. It would also be good to avoid conflict with LoggingEvent, so the obvious choices are LoggingRecord and LogEvent. I'd prefer LoggingRecord. I think it is probably best to choose an existing jul name for methods since the Java naming cops likely did a pretty through review and we can link to the platform Javadoc for elaboration when the concepts are identical.


While I agree that Sun probably has done a few good things, I wouldn't necessarily automatically defer to their naming convention. Lets face it, they _still_ have the 'thing' that is called a Java bug database, one of the most appalling tools I've ever had the mispleasure to use. They, like everyone else, can do dumb things from time to time (why is java.util.logging.Handler a class and not an interface for example?) So, if a name does feel good, I'm happy to use their names, however I wouldn't want to blanket borrow from them.

I don't mind LogEvent personally, but LoggingRecord isn't too bad either.

Paul

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to