jenkins-bot has submitted this change and it was merged. ( 
https://gerrit.wikimedia.org/r/401754 )

Change subject: Remove unneeded @codingStandardsIgnoreLine from test
......................................................................


Remove unneeded @codingStandardsIgnoreLine from test

Just put the failing message into .expected like done in other tests
This removes a reference to an already deleted sniff

Change-Id: I0f4148bbbafec7b1209ec17c28567325cb058f25
---
M MediaWiki/Tests/files/NamingConventions/function_name.php
M MediaWiki/Tests/files/NamingConventions/function_name.php.expect
2 files changed, 3 insertions(+), 2 deletions(-)

Approvals:
  Hashar: Looks good to me, approved
  jenkins-bot: Verified



diff --git a/MediaWiki/Tests/files/NamingConventions/function_name.php 
b/MediaWiki/Tests/files/NamingConventions/function_name.php
index c293dcb..b7ca77f 100644
--- a/MediaWiki/Tests/files/NamingConventions/function_name.php
+++ b/MediaWiki/Tests/files/NamingConventions/function_name.php
@@ -50,7 +50,6 @@
 /**
  * Unit tests have different naming conventions.
  */
-// @codingStandardsIgnoreLine MediaWiki.Files.OneClassPerFile.MultipleFound
 class FooTest {
        /**
         * Standard way of naming a test for someMethod when there are multiple 
tests for it.
diff --git a/MediaWiki/Tests/files/NamingConventions/function_name.php.expect 
b/MediaWiki/Tests/files/NamingConventions/function_name.php.expect
index a57e0d4..2588c43 100644
--- a/MediaWiki/Tests/files/NamingConventions/function_name.php.expect
+++ b/MediaWiki/Tests/files/NamingConventions/function_name.php.expect
@@ -7,6 +7,8 @@
  46 | ERROR | Function name "testSomeMethod_foo" should use lower camel
     |       | case.
     |       | 
(MediaWiki.NamingConventions.LowerCamelFunctionsName.FunctionName)
- 73 | ERROR | Function name "helper_method" should use lower camel
+ 53 | ERROR | Only one object structure is allowed in a file
+    |       | (Generic.Files.OneObjectStructurePerFile.MultipleFound)
+ 72 | ERROR | Function name "helper_method" should use lower camel
     |       | case.
     |       | 
(MediaWiki.NamingConventions.LowerCamelFunctionsName.FunctionName)
\ No newline at end of file

-- 
To view, visit https://gerrit.wikimedia.org/r/401754
To unsubscribe, visit https://gerrit.wikimedia.org/r/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I0f4148bbbafec7b1209ec17c28567325cb058f25
Gerrit-PatchSet: 1
Gerrit-Project: mediawiki/tools/codesniffer
Gerrit-Branch: master
Gerrit-Owner: Umherirrender <umherirrender_de...@web.de>
Gerrit-Reviewer: Addshore <addshorew...@gmail.com>
Gerrit-Reviewer: Hashar <has...@free.fr>
Gerrit-Reviewer: Legoktm <lego...@member.fsf.org>
Gerrit-Reviewer: jenkins-bot <>

_______________________________________________
MediaWiki-commits mailing list
MediaWiki-commits@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/mediawiki-commits

Reply via email to