On 07/19/2016 07:14 PM, Józef Kucia wrote:
On Mon, Jul 18, 2016 at 10:55 PM, Samuel Pitoiset
<samuel.pitoi...@gmail.com> wrote:
+   } else if (insn->tex.target == TEX_TARGET_2D_ARRAY ||
+              insn->tex.target == TEX_TARGET_CUBE ||
+              insn->tex.target == TEX_TARGET_CUBE_ARRAY) {
+      target = 8;
+   } else if (insn->tex.target == TEX_TARGET_3D ||
+              insn->tex.target == TEX_TARGET_CUBE_ARRAY) {
+      target = 10;

TEX_TARGET_CUBE_ARRAY is listed twice. Apart from that a switch
statement might be more readable.

Good catch, thanks!


_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to