On Wed, 15 Oct 2008, Eric Holtzclaw wrote:

Is it possible to get the MT OS to: Have a user start a external port 80 request that will start a ping session to enabled a Wake on LAN for a server in side of the network?

Ok...here's a quickie..only barely tested. You should probably use more variables where I have constants. You need to create a firewall rule in the input chain on a port that is NOT used for anything else:

/ip firewall filter add chain=input protocol=tcp dst-port=8473 \
    action=passthrough comment="PINGWOL"

Be sure the above rule is not going to be dropped (put it at or near the top of the chain).

Then use a script similar to the following(some lines wrapped in my email program):

:local packet [/ip firewall filter get [find comment="PINGWOL"] packets]

:if ( $"packet"  > 0) do={

/ip firewall filter reset-counters [/ip firewall filter find comment="PINGWOL"]

    /ping 10.10.10.10 count=5

    :log error "Pinging the WOL device"

} else={

    :log error "No packets, yet"
}


--
********************************************************************
*Butch Evans                    *Professional Network Consultation *
*Network Engineering            *MikroTik RouterOS                 *
*573-276-2879                   *ImageStream                       *
*http://www.butchevans.com/     *StarOS and MORE                   *
*http://blog.butchevans.com/    *Wired or wireless Networks        *
*http://www.wisp-forums.com/    *http://www.wisp-wiki.com/
*Mikrotik Certified Consultant  *Professional Technical Trainer    *
********************************************************************

Reply via email to