On 01/14/2014 12:20 PM, Jerry Roy wrote:
I need some help here. I am using the example below from the wiki on
queuing but I want to give preference to certain ports and protocols. How
would I modify the following to do what I require? I see no way of
specifying udp 4500 which is an aruba doing ssl (which all voip phones are
connected to) that is hanging off our 750's. Am I barking up the wrong
tree? What would you recommend?

You would add appropriate mangle rules to create packet marks that would move traffic into the below queues, or you could create a new packet mark and add the queues in the appropriate place in your queue structure.

/queue tree
add name="IN" parent=global-in priority=1
add name="OUT" parent=global-out priority=1
add name="SIP_IN" packet-mark=SIP_IN parent=IN priority=2
add name="SIP_OUT" packet-mark=SIP_OUT parent=OUT priority=2
add name="NAT-T_IN" packet-mark=NAT-T_IN parent=IN priority=3
add name="NAT-T_OUT" packet-mark=NAT-T_OUT parent=OUT priority=3
add name="ALL_ELSE_IN" packet-mark=ELSE_IN parent=IN priority=8
add name="ALL_ELSE_OUT" packet-mark=ELSE_OUT parent=OUT priority=8

Priority is not relevant for inner queue nor for leaf queues that do not have a max-limit specified. A proper configuration would include limit-at as well, so that you have a complete htb implementation.


It may be helpful for you to read the wiki entry about htb as well. This can be found here:
http://wiki.mikrotik.com/wiki/HTB

--
Butch Evans
702-537-0979
Network Support and Engineering
http://store.wispgear.net/
http://www.butchevans.com/
_______________________________________________
Mikrotik mailing list
Mikrotik@mail.butchevans.com
http://mail.butchevans.com/mailman/listinfo/mikrotik

Visit http://blog.butchevans.com/ for tutorials related to Mikrotik RouterOS

Reply via email to