On Mon, Oct 05, 2026 at 10:02:11PM +0000, Sylvain Saboua wrote:
> I am in the process of setting up a Docker container for
> Jellyfin in an Alpine Linux virtual machine.
>
> I am stuck at trying to mount the /var/www/media/.jellyfin
> folder from the OpenBSD host (srv) in the Alpine virtual
> machine (media):
>
> media:~# rc-service nfsmount start
>  * Starting NFS sm-notify ...
>  [ ok ]
>  * Mounting NFS filesystems ...
> mount.nfs: requested NFS version or transport protocol is not supported for
> /home/media/jellyfin
> mount: mounting 100.64.1.2:/var/www/media/.jellyfin on /home/media/jellyfin
> failed: Not supported
>  [ !! ]
>  * ERROR: nfsmount failed to start
> media:~#
>
> Here is my configuration:
>
> srv$ cat /etc/exports
> /var/www/media -maproot=media -network=10.0.0 -mask=255.255.255.0
> /var/www/media/.jellyfin -maproot=media -network=100.64.1
> -mask=255.255.255.0
>
> fstab line in the Alpine virtual machine:
> 100.64.1.2:/var/www/media/.jellyfin /home/media/jellyfin nfs
> rw,_netdev,vers=3 0 0
>
> Any clue ?
>
> PS these are the tutorials I am following:
> https://www.openbsd.org/faq/faq16.html
> https://www.tumfatig.net/2022/running-docker-host-openbsd-vmd/
> https://jellyfin.org/docs/general/installation/container/?method=docker-cli
> --
> Sylvain Saboua
> looking for a PDP-11
>

i do something similar with a local jellyfin vm on vmm (on ubuntu not alpine
but it probably shouldnt matter).

/etc/fstab on vm:
server:/Media   /Media          nfs     soft,intr,tcp   0 1

/etc/exports on the host looks like yours.

Reply via email to