Matt Sergeant's message:
>
>On Fri, 11 Aug 2000, Ken Williams wrote:
>
>> Hi Matt,
>> 
>> Is it possible that this functionality should be integrated into
>> Apache::StatInc?  Perhaps with a couple of new directives to control
>> behavior?
>
>Thats a difficult one... Of course its possible to do, but is it
>sensible? It would basically make StatINC a two-mode module. In one mode
>it stats @INC, like its name suggests, and in another it only stats
>modules that have use()'d it. I would have thought Apache::Reload would
>then be a better name for it, overall.

That seems right - so perhaps it would be better to integrate the
StatINC functionality into Apache::Reload than the other way around.
If it's called Apache::Reload, then it might make sense to have a
directive like 'ReloadMode' that could be set to 'INC' to emulate
StatINC's behavior, or to 'Files' to explicitly name the files you
want checked with every request, or to 'Slave' (perhaps a bad choice)
to only check those files that do the "use Apache::Reload" thingy
you've written.

'Files' and 'INC' wouldn't be very different in implementation, but
'Files' gives you finer-grained control.  They both just take a list
of files and check them with every request.

One nice thing about this approach is that you could set the
ReloadMode differently for different URI files/directories in
httpd.conf, so you wouldn't have to shotgun your entire site when you
just need to test one little thing in your private area.

It might be nice to have only one [main] module for reloading changed
code files, both because of memespace issues and because the actual
reloading task seems to be a tricky one, and it would be nice to only
have to get it right once.  But if it doesn't make sense to combine
the approaches into one module, it doesn't make sense.


-Ken Williams
 The Math Forum
 [EMAIL PROTECTED]

Reply via email to