This call worked in older versions of the SDK, but with the LDAP SDK
5.0 you cannot have "cert7.db" in the path. It must be:

        ldapssl_client_init( "c:\\foo\\bar", NULL ) // works

tho i personally wasnt involved at the time i believe the reason
for the change lies in NSS init interface/s changes. deprecated
function ldap_pkcs_init() which still works but pretty much pain
in the butt to use allows for diff names and prefixes as it does
call NSS_Initialize() further down the line instead of NSS_Init()
used by current, non deprecated functions. NSS_Init() allows for
one arg only and that arg should be sec db path ending which is
a *folder* name in case of NSS_Init(). problem is, you shouldnt
be doing this really. obviously its up to you but NSS sec db can
change naming scheme at any moment eg relatively recent move from
cert7 to cert8 format so imho its best to stay out of this and
let NSS itself deal with its sec db structure and naming. try
switching to folders, there is no limitation i can think of if
you do that.

This is very annoying -- it is both a regression and contrary to the
docs. Anyway, thought I'd post this in case anyone else experiences
the same problem.

i'm with you on this one and i'm actually thinking of introducing
a new init interface [ in addition to half a dozen we have already
in there :( ], some form of single but advanced api that should
take care of custom secdb names and prefixes if api user is willing
[ for whatever reason ] to work with customized NSS sec db naming.
i would like to know what others here think of this and any ideas
on how it should be implemented etc and what things it must cover.
for now we are keeping ldap_pkcs_init() which i resurrected with
some fixes as it was neglected for awhile being deprecated and all.

http://docs.iplanet.com/docs/manuals/dirsdk/csdk41/html/function.htm#...

use this one instead : http://docs.sun.com/source/817-6707/
tho i'm pretty sure it still mention sec db filenames coz
at the time of writing we were still using old NSS release.
next release of the doc should be up to date on that stuff.
_______________________________________________
mozilla-directory mailing list
mozilla-directory@mozilla.org
http://mail.mozilla.org/listinfo/mozilla-directory

Reply via email to