Hi 

I propose we remove the following functions

These were declared obsolete sometime in 2000-2002
void mpz_random (mpz_t ROP, mp_size_t MAX_SIZE)
void mpz_random2 (mpz_t ROP, mp_size_t MAX_SIZE)

These were declared obsolete in Apr 2000-2002
mp_limb_t mpn_divrem (mp_limb_t *R1P, mp_size_t QXN,
          mp_limb_t *RS2P, mp_size_t RS2N, const mp_limb_t *S3P,
          mp_size_t S3N)
 mp_limb_t mpn_divmod (mp_limb_t *R1P, mp_limb_t *RS2P,
          mp_size_t RS2N, const mp_limb_t *S3P, mp_size_t S3N)

This was declared obsolete in Nov 2001
void gmp_randinit (gmp_randstate_t STATE,gmp_randalg_t ALG, ...)

I think the functions below should be declared obsolete

This is dangerous function 
void mpz_array_init (mpz_t INTEGER_ARRAY, size_t
          ARRAY_SIZE, mp_size_t FIXED_NUM_BITS)
in that anyone using it has to make assumptions about how we have implemented 
the mpz functions using its variables.We are not likely to break the 
assumptions, they are reasonable. We could perhaps provide a completely safe 
alternative.

int mpz_probab_prime_p (mpz_t N, int REPS)
is mathematical rubbish , the random numbers used are the same for each 
invocation. We should replace this with a robust alternative that (at least) 
accepts a "gmp_randstate_t" 


void mpz_nextprime (mpz_t ROP, mpz_t OP)
Bad choice of names , we should rename it mpz_next_probab_prime(...)

The mpf layer , as its full of bugs,untested code and bad definitions. It 
consumes our time and effort and offers nothing in return.

Jason


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"mpir-devel" group.
To post to this group, send email to mpir-devel@googlegroups.com
To unsubscribe from this group, send email to 
mpir-devel+unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/mpir-devel?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to