On 2008/09/02 05:13, Eric Wong <[EMAIL PROTECTED]> wrote:
> Ugh, the amount of wrapper functions we have is getting to my nerves.
> Also, I've seen xfree() in the past as a macro that NULLs its argument,
> so I'd rather not use that function name for something that does
> something completely different.
> 
> Instead, I'm just going to use this instead and remove all of
> our other wrappers.

I know it's getting crowded, but I decided to add another wrapper
instead of the generic "deconst_ptr()", because deconsting is a "bad
thing" which you should only do when you "really know what you're
doing".  A generic function like "deconst_ptr()" encourages careless
deconsting everywhere.  And it discourages bothering the library
authors to correct their API declarations.

Max

-------------------------------------------------------------------------
This SF.Net email is sponsored by the Moblin Your Move Developer's challenge
Build the coolest Linux based applications with Moblin SDK & win great prizes
Grand prize is a trip for two to an Open Source event anywhere in the world
http://moblin-contest.org/redirect.php?banner_id=100&url=/
_______________________________________________
Musicpd-dev-team mailing list
Musicpd-dev-team@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/musicpd-dev-team

Reply via email to