H Jeremy!

> > tblNews
> > intpkNewsID
> > intfkUsersID
> > datPosted
> > varSubject
> > txtContent
> > blnBoolean
>
> Wow, that's rather cluttered.  I'd rather use a readable standard.
> Won't it be a bit strange when you run SHOW TABLES and you get a bunch
> things back all that being with "tbl"?

So make them easier to read such as tbl_news and bln_boolean. Or shorten
it a little with tb_news and tx_content.

It's not as weird as you think. If you get back a column of stuff all
prefixed with tbl_ your eye will simply slide over it and ignore it. The
table that is returned -without- a tbl_, or the one with the thl_ typo
will stand out like a sore thumb as an obvious error and maybe even help
fix whatever problem you're troubleshooting.

> When you program, do you prefix every variable name with "var"?  Every
> function name with "func"?  Every macro with "mac"?

Vars, no, because there are more of them than anyting else. The word that
-doesn't- have a prefix is a var. :) But everything else, yes. Because
even though it's clear in my head 'now' what I'm doing, I *know* that six
months down the road when I look at it again I won't remember -anything!-
LOL! Been there done that waaaay too many times to not plan ahead for
brain-fade.

> Do the filenames on your computer all begin with "file" and folders
> "fldr"?

No, because I have no files on my computer that aren't files, and I have
no subdirectories that don't have a 'd' at the top of the line. :)

But I don't have any perl scripts that aren't *.pl or SSI includes that
aren't *.inc.

The point of all this is to make it it easier to read -later-. A tbl_ is
clearly a table and a b_ is clearly a boolean without having to think
about it or 'remember' or look it up elsewhere. Such as 'I need to test
this variable but is it a boolean or a text, now I gotta go find where
it's defined.' Writing code is easy. Today. Troubleshooting an obscure
error months later, or modifying things to add a new feature is -work-. :)
A little up front efort -will- help further down the line.

Have a :) day!

-- 
jim barchuk
[EMAIL PROTECTED]


---------------------------------------------------------------------
Before posting, please check:
   http://www.mysql.com/manual.php   (the manual)
   http://lists.mysql.com/           (the list archive)

To request this thread, e-mail <[EMAIL PROTECTED]>
To unsubscribe, e-mail <[EMAIL PROTECTED]>
Trouble unsubscribing? Try: http://lists.mysql.com/php/unsubscribe.php

Reply via email to