Hi Ian, What's the general practice for attribute names regarding case ?
Should new properties always be lowercase or should we also use mixed-case properties ? If we can also use mixed-case properties, then I assume the first letter should be lower-case (camel case), right ? for example, I recently added the useruntimeengine attribute on the ExternalProgramBase class. I think it would definitely improve readability if we could use a mixed-case attribute name (useRuntimeEngine) for this attribute. If we do that, then I guess we should also use mixed-case names in the task configuration in the NAnt configuration file (right now the framework-configuration attribute for that attribute is called useruntimeengine). What do you think ? Gert ------------------------------------------------------- This SF.Net email sponsored by: Free pre-built ASP.NET sites including Data Reports, E-commerce, Portals, and Forums are available now. Download today and enter to win an XBOX or Visual Studio .NET. http://aspnet.click-url.com/go/psa00100003ave/direct;at.aspnet_072303_01/01 _______________________________________________ nant-developers mailing list [EMAIL PROTECTED] https://lists.sourceforge.net/lists/listinfo/nant-developers
