Gert Driesen wrote:

----- Original Message ----- From: "Ian MacLean" <[EMAIL PROTECTED]>
To: "Gert Driesen" <[EMAIL PROTECTED]>
Cc: "Nant-Developers (E-Mail)" <[EMAIL PROTECTED]>
Sent: Monday, August 18, 2003 1:17 PM
Subject: Re: general practice for attribute names


I'm fairly sure that we had agreed on lower case for the build file.



I probable wasn't yet involved with NAnt development when this was agreed upon, but I have no problems with it if this was agreed upon.

I'm pretty sure you were since we had a discussion on whether it was better to conform to the enum naming guidelines or the nant lowercase convention for buildfiles. Or maybe that was Scott :)



useRuntimeEngine is more readable
but now you have to work out whether or not the attribute is case
sensitive before you use it.



but having all lower-case attribute names of that size can introduce more typo's ...

making them smaller might help. 'ismanaged' instead of 'useRuntimeEngine'

I'll check thru the archives and find the old discussion threads on this.

Ian



-------------------------------------------------------
This SF.Net email sponsored by: Free pre-built ASP.NET sites including
Data Reports, E-commerce, Portals, and Forums are available now.
Download today and enter to win an XBOX or Visual Studio .NET.
http://aspnet.click-url.com/go/psa00100003ave/direct;at.aspnet_072303_01/01
_______________________________________________
nant-developers mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/nant-developers

Reply via email to