nettle-bugs
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: Require GNU make?
Niels Möller
Re: Require GNU make?
George Koehler
Re: Require GNU make?
Niels Möller
[PATCH 1/3] Change ecc_mod_*mul_1 to be per-module callbacks
dbaryshkov
[PATCH 2/3] Add several GOST R 34.10 curves defined by RFC 4357 and RFC 7836
dbaryshkov
Re: [PATCH 2/3] Add several GOST R 34.10 curves defined by RFC 4357 and RFC 7836
Niels Möller
[PATCH 3/3] Add GOST DSA according to GOST R 34.10-2001/-2012
dbaryshkov
Re: [PATCH 1/3] Change ecc_mod_*mul_1 to be per-module callbacks
Niels Möller
[PATCH v3 0/3] ecc: rename to contain full curve name
dbaryshkov
[PATCH v3 1/3] ecc: rename source files with curves data
dbaryshkov
[PATCH v3 3/3] ecc: rename functions to contain curve names instead of bits
dbaryshkov
[PATCH v3 2/3] ecc: prefix optimized ECC function names with underscore
dbaryshkov
Re: [PATCH v3 2/3] ecc: prefix optimized ECC function names with underscore
Niels Möller
Re: [PATCH v3 2/3] ecc: prefix optimized ECC function names with underscore
Dmitry Eremin-Solenikov
Re: [PATCH v3 2/3] ecc: prefix optimized ECC function names with underscore
Niels Möller
Re: [PATCH v3 2/3] ecc: prefix optimized ECC function names with underscore
Dmitry Eremin-Solenikov
update CI to latest fedora image
Nikos Mavrogiannopoulos
Re: update CI to latest fedora image
Nikos Mavrogiannopoulos
Re: update CI to latest fedora image
Niels Möller
Re: update CI to latest fedora image
Nikos Mavrogiannopoulos
Re: update CI to latest fedora image
Niels Möller
Current ECC work
Niels Möller
Re: Current ECC work
Dmitry Eremin-Solenikov
Re: Current ECC work
Niels Möller
Re: Current ECC work
Nikos Mavrogiannopoulos
Re: Current ECC work
Niels Möller
Re: Current ECC work
Niels Möller
[PATCH v2 1/3] ecc: rename source files with curves data
dbaryshkov
[PATCH v2 2/3] ecc: prefix optimized ECC function names with underscore
dbaryshkov
[PATCH v2 3/3] ecc: rename functions to contain curve names instead of bits
dbaryshkov
[PATCH 1/3] ecc: rename source files with curves data
dbaryshkov
[PATCH 3/3] ecc: rename functions to contain curve names instead of bits
dbaryshkov
[PATCH 2/3] ecc: prefix optimized ECC function names with underscore
dbaryshkov
post-quantum crypto algorithms implementation
johnjmar
Re: post-quantum crypto algorithms implementation
Niels Möller
Re: post-quantum crypto algorithms implementation
Jeffrey Walton
[PATCH v2] ecc: rename source files with curves data
dbaryshkov
patch: fix check for __builtin_bswap64
George Koehler
Re: patch: fix check for __builtin_bswap64
Niels Möller
Re: patch: fix check for __builtin_bswap64
Jeffrey Walton
Re: patch: fix check for __builtin_bswap64
George Koehler
rsa too slow?
Nikos Mavrogiannopoulos
Re: rsa too slow?
Simo Sorce
Re: rsa too slow?
Niels Möller
Re: rsa too slow?
Nikos Mavrogiannopoulos
Re: rsa too slow?
Nikos Mavrogiannopoulos
Re: rsa too slow?
Niels Möller
git clone is unreliable for nettle
Tim Rühsen
Re: git clone is unreliable for nettle
Nikos Mavrogiannopoulos
Re: git clone is unreliable for nettle
Tim Rühsen
Re: git clone is unreliable for nettle
Niels Möller
[RFC] ecc: switch away from affine points representation
dbaryshkov
Re: [RFC] ecc: switch away from affine points representation
Niels Möller
Re: [RFC] ecc: switch away from affine points representation
Niels Möller
Re: [RFC] ecc: switch away from affine points representation
Dmitry Eremin-Solenikov
Re: [RFC] ecc: switch away from affine points representation
Niels Möller
Re: [RFC] ecc: switch away from affine points representation
Dmitry Eremin-Solenikov
Re: [RFC] ecc: switch away from affine points representation
Niels Möller
[PATCH] ecc: rename source files with curves data
dbaryshkov
Re: [PATCH] ecc: rename source files with curves data
Dmitry Eremin-Solenikov
Re: [PATCH] ecc: rename source files with curves data
Dmitry Eremin-Solenikov
Re: [PATCH] ecc: rename source files with curves data
Niels Möller
ECC code rework
Dmitry Eremin-Solenikov
Re: ECC code rework
Niels Möller
Re: ECC code rework
Niels Möller
Re: ECC code rework
Niels Möller
Re: ECC code rework
Dmitry Eremin-Solenikov
Re: ECC code rework
Niels Möller
Re: ECC code rework
Dmitry Eremin-Solenikov
Re: ECC code rework
Niels Möller
Re: ECC code rework
Dmitry Eremin-Solenikov
Re: ECC code rework
Niels Möller
Re: ECC code rework
Dmitry Eremin-Solenikov
Nettle ECC code question
Dmitry Eremin-Solenikov
Re: Nettle ECC code question
Simo Sorce
Re: Nettle ECC code question
Dmitry Eremin-Solenikov
Re: Nettle ECC code question
Niels Möller
Re: Nettle ECC code question
Dmitry Eremin-Solenikov
Re: Nettle ECC code question
Niels Möller
PowerMac G5 results
Jeffrey Walton
Re: PowerMac G5 results
Niels Möller
Re: PowerMac G5 results
Jeffrey Walton
charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Daniel Kahn Gillmor
Re: charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Niels Möller
Re: charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Daniel Kahn Gillmor
Re: charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Daniel P . Berrangé
Re: charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Wim Lewis
Re: charset parameter for https://www.lysator.liu.se/~nisse/nettle/nettle.html causing mojibake
Tim Rühsen
[PATCH 1/2] Implement GOST R 34.11-2012 (Streebog) hash function
dbaryshkov
[PATCH 2/2] Implement PBKDF2 shortcut function for Streebog256/512
dbaryshkov
Re: [PATCH 1/2] Implement GOST R 34.11-2012 (Streebog) hash function
Dmitry Eremin-Solenikov
[PATCH 1/2] Implement GOST R 34.11-2012 (Streebog) hash function
Dmitry Baryshkov
[PATCH 2/2] test/gostdsa-vko: add hashed test vectors from RFC 7836
Dmitry Baryshkov
Re: [PATCH 1/2] Implement GOST R 34.11-2012 (Streebog) hash function
Niels Möller
Re: [PATCH 1/2] Implement GOST R 34.11-2012 (Streebog) hash function
Dmitry Baryshkov
[PATCH] cfb8: don't truncate output IV if input is shorter than block size
Daiki Ueno
Re: [PATCH] cfb8: don't truncate output IV if input is shorter than block size
Niels Möller
Re: [PATCH] cfb8: don't truncate output IV if input is shorter than block size
Daiki Ueno
Re: [PATCH] cfb8: don't truncate output IV if input is shorter than block size
Niels Möller
[PATCH 0/5] GOST 28147-89 support
dbaryshkov
[PATCH 4/5] Add special CNT mode for GOST 28147-89 cipher
dbaryshkov
[PATCH 3/5] Add CFB mode support for GOST 28147-89
dbaryshkov
[PATCH 1/5] Add GOST 28147-89 ECB encryption and decryption support
dbaryshkov
[PATCH 5/5] Add GOST 28147-89 IMIT support
dbaryshkov
[PATCH 2/5] Add the rest of sboxes for GOST 28147
dbaryshkov
[PATCH v2 1/4] block-internal: add block XORing functions
dbaryshkov
[PATCH v2 3/4] gcm: move block shifting function to block-internal.h
dbaryshkov
Re: [PATCH v2 3/4] gcm: move block shifting function to block-internal.h
Niels Möller
Re: [PATCH v2 3/4] gcm: move block shifting function to block-internal.h
Dmitry Eremin-Solenikov
[PATCH v2 4/4] gcm: drop intermediate GCM_TABLE_BITS == 4 case
dbaryshkov
Re: [PATCH v2 4/4] gcm: drop intermediate GCM_TABLE_BITS == 4 case
Niels Möller
[PATCH v2 2/4] block modes: move Galois shifts to block-internal.h
dbaryshkov
[PATCH 1/5] gcm: use uint64_t member of nettle_block16
dbaryshkov
[PATCH 3/5] block-internal: add block XORing functions
dbaryshkov
Re: [PATCH 3/5] block-internal: add block XORing functions
Niels Möller
Re: [PATCH 3/5] block-internal: add block XORing functions
Dmitry Eremin-Solenikov
[PATCH 2/5] cmac64: fix nettle_block16 usage
dbaryshkov
[PATCH 4/5] block modes: move Galois shifts to block-internal.h
dbaryshkov
Re: [PATCH 4/5] block modes: move Galois shifts to block-internal.h
Niels Möller
Re: [PATCH 4/5] block modes: move Galois shifts to block-internal.h
Dmitry Eremin-Solenikov
[PATCH 5/5] gcm: move block shifting function to block-internal.h
dbaryshkov
PPC64le GHASH Vector Acceleration
johnjmar
[PATCH] nettle-meta: add meta interface for CMAC-DES3 functions
dbaryshkov
Swift language bindings, a work in progress
Wim Lewis
[PATCH v2 0/6] Add meta interface for MAC algorithms
Daiki Ueno
[PATCH v2 3/6] nettle-meta: Add meta interface for HMAC functions
Daiki Ueno
Re: [PATCH v2 3/6] nettle-meta: Add meta interface for HMAC functions
Niels Möller
Re: [PATCH v2 3/6] nettle-meta: Add meta interface for HMAC functions
Dmitry Eremin-Solenikov
Re: [PATCH v2 3/6] nettle-meta: Add meta interface for HMAC functions
Niels Möller
[PATCH v2 2/6] nettle-meta: Add meta interface for CMAC functions
Daiki Ueno
[PATCH v2 5/6] nettle-meta: Expose all defined MACs through nettle_macs
Daiki Ueno
[PATCH v2 6/6] tests: Add test for meta interface for MAC algorithms
Daiki Ueno
[PATCH v2 4/6] nettle-meta: Add meta interface for UMAC functions
Daiki Ueno
[PATCH v2 1/6] nettle-meta: Move struct nettle_mac to nettle-meta.h
Daiki Ueno
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Niels Möller
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Niels Möller
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Daiki Ueno
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Niels Möller
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Niels Möller
Re: [PATCH v2 0/6] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
[PATCH 0/7] Add meta interface for MAC algorithms
Daiki Ueno
[PATCH 2/7] nettle-meta: Move struct nettle_mac to nettle-meta.h
Daiki Ueno
[PATCH 4/7] nettle-meta: Add meta interface for HMAC functions
Daiki Ueno
[PATCH 6/7] nettle-meta: Expose all defined MACs through nettle_macs
Daiki Ueno
[PATCH 1/7] hmac: Add set_key_expanded function
Daiki Ueno
Re: [PATCH 1/7] hmac: Add set_key_expanded function
Dmitry Eremin-Solenikov
[PATCH 3/7] nettle-meta: Add meta interface for CMAC functions
Daiki Ueno
[PATCH 5/7] nettle-meta: Add meta interface for UMAC functions
Daiki Ueno
[PATCH 7/7] tests: Add test for meta interface for MAC algorithms
Daiki Ueno
Re: [PATCH 0/7] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
Re: [PATCH 0/7] Add meta interface for MAC algorithms
Daiki Ueno
Re: [PATCH 0/7] Add meta interface for MAC algorithms
Dmitry Eremin-Solenikov
Some .stamp files slipped into the tarball
Justus Winter
Re: Some .stamp files slipped into the tarball
Niels Möller
Re: Some .stamp files slipped into the tarball
Justus Winter
Re: Some .stamp files slipped into the tarball
Niels Möller
Re: Some .stamp files slipped into the tarball
Justus Winter
Re: Some .stamp files slipped into the tarball
Niels Möller
Rust bindings
Justus Winter
Re: Rust bindings
Niels Möller
Re: Rust bindings
Justus Winter
Re: Rust bindings
Justus Winter
Re: Rust bindings
Niels Möller
[PATCH 1/2] Sort bindings alphabetically.
justus
[PATCH 2/2] Link to Rust bindings.
justus
Dead links to bindings (was: Rust bindings)
Justus Winter
Re: Dead links to bindings
Niels Möller
nettle-meta interface for MACs
Daiki Ueno
Re: nettle-meta interface for MACs
Niels Möller
Re: nettle-meta interface for MACs
Daiki Ueno
[PATCH v2 0/3] Add support for deterministic DSA/ECDSA (RFC 6979)
Daiki Ueno
[PATCH v2 3/3] dsa: Add support for deterministic signature generation
Daiki Ueno
[PATCH v2 1/3] dsa: Add a function to find k deterministically
Daiki Ueno
[PATCH v2 2/3] ecdsa: Add support for deterministic signature generation
Daiki Ueno
[PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Dmitry Eremin-Solenikov
[PATCH v2 5/6] Add HMAC functions for GOSTHASH94 and GOSTHASH94CP
Dmitry Eremin-Solenikov
[PATCH v2 4/6] Add GOST R 34.11-94 to nettle_hashes
Dmitry Eremin-Solenikov
[PATCH v2 2/6] Add support for GOSTHASH94CP: GOST R 34.11-94 hash with CryptoPro S-box
Dmitry Eremin-Solenikov
[PATCH v2 3/6] gosthash94: switch to using MD_UPDATE() macro
Dmitry Eremin-Solenikov
Re: [PATCH v2 3/6] gosthash94: switch to using MD_UPDATE() macro
Niels Möller
[PATCH v2 6/6] Add PBKDF2 support for gosthash94cp
Dmitry Eremin-Solenikov
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Dmitry Eremin-Solenikov
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Niels Möller
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Dmitry Eremin-Solenikov
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Dmitry Eremin-Solenikov
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Niels Möller
Re: [PATCH v2 1/6] Start separating GOST 28147-89 from GOST R 34.11-94
Dmitry Eremin-Solenikov
[PATCH v2 0/3] drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH v2 1/3] eax: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH v2 2/3] gcm: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH v2 3/3] nettle-types: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH 1/3] eax: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH 3/3] nettle-types: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH 2/3] gcm: drop w field from nettle_block16
Dmitry Eremin-Solenikov
Re: [PATCH 2/3] gcm: drop w field from nettle_block16
Niels Möller
Re: [PATCH 2/3] gcm: drop w field from nettle_block16
Dmitry Eremin-Solenikov
[PATCH] nettle-types: drop w field from nettle_block16
Dmitry Eremin-Solenikov
Earlier messages
Later messages