On Fri, 5 May 2023 20:20:02 GMT, John Hendrikx <jhendr...@openjdk.org> wrote:

> > I'm not quite sold on having `notifyKey` and `notifyKeyEx` be two separate 
> > methods. Why not just have one? Not changing the existing call sites 
> > doesn't seem to be a sufficient reason to expand the toolkit API surface.
> 
> I also think it isn't really needed; Mac and Linux can just ignore the extra 
> parameter for now?

I now realize that there's no reason for `notifyKey` and `notifyKeyEx` to have 
unique names since `GetMethodID` has no problem distinguishing between Java 
overloads. I'll be tweaking this PR to rename `notifyKeyEx` to `notifyKey` so I 
won't have to get rid of the clunky name in a separate pass.

Mac and Linux will migrate naturally to the new version of `notifyKey` as I fix 
bugs related to accelerator handling. The remaining clients would be iOS and 
Monocle. If we're still determined to stamp out the older version it would make 
sense to tweak iOS at the same time as the Mac since that's where the 
cross-compilation would happen.

Both versions of `notifyKey` are one-liners that pass their parameters on to 
the same internal routine (the older version just defaults the `hardwareCode`). 
I'm still not convinced that it's worth the effort to mess with iOS and Monocle 
to make the older version go away.

-------------

PR Comment: https://git.openjdk.org/jfx/pull/1126#issuecomment-1542796058

Reply via email to