On Tue, 25 Aug 2026 19:26:47 GMT, Andy Goryachev <[email protected]> wrote:
>> John Hendrikx has updated the pull request with a new target base due to a >> merge or a rebase. The pull request now contains nine commits: >> >> - Remove whitespace >> - Add @since to RenderScaleContext >> - Merge remote-tracking branch 'origin/master' into feature/layoutable >> - Add BorderPaneLayout >> >> - Fix snapToPixel not calling requestLayout >> - Fix shadowing of arguments in StackPaneLayout >> - Remove Snapper.DEFAULT to Snapper.IDENTITY >> - Add missing @Override >> - Add missing @Since on public types >> - Minor javadoc adjustments >> - Rename LayoutSupport to LayoutUtils >> - Fix types and removed redundant isResizable checks >> - Address some review comments >> - Remove white space at end of line >> - Add StackPaneLayout, move Region helpers to LayoutSupport >> - Create new interfaces Layoutable and Measurable and use by Node > > Looks like this might depend on @mstr2 's snapping work. > Maybe we ought to focus on #2262 first to avoid merging conflicts later. > What do you think? @andy-goryachev-oracle the merge was nastier than I thought it would be, but it should be all good and RFR again now with all changes @mstr2 did in #2278 incorporated. ------------- PR Comment: https://git.openjdk.org/jfx/pull/2241#issuecomment-5587372096
