On Tue, 8 Sep 2026 22:16:27 GMT, Andy Goryachev <[email protected]> wrote:

> # Monkey Tester Update 8
> 
> Further additions to the built-in MonkeyTester application.
> 
> 
> ### Improvements
> 
> - ComboBox page: button cell, cell factory options
> - ClipboardPage: new viewer, copy options
> - Drag and Drop: logging options
> - MenuBar: menus with various accelerators
> - RichTextArea: drag and drop handler, tab stops, highlight, embedded image 
> options
> - ShapePage: dash options
> 
> 
> ### Tools
> 
> - updated Clipboard Viewer
> 
> 
> ### Miscellaneous
> 
> - Skin -> Skin Structure (to stdout)
> - MainWindow `title=` command line argument
> 
> ---------
> - [x] I confirm that I make this contribution in accordance with the [OpenJDK 
> Interim AI Policy](https://openjdk.org/legal/ai).

Took a quick look at the changes and they look good, testing I found one minor 
thing in ShapePage that was from one of the earlier updates that we could also 
fix with this update.

tests/manual/monkey/src/com/oracle/tools/fx/monkey/pages/ShapePage.java line 
218:

> 216:             return new Rectangle(0, 0, 400, 200);
> 217:         });
> 218:         op.addChoice("Text", () -> {

This is not related to this change but testing ShapePage I just noticed - this 
shape choice should be named "Cubic Curves" while the one below it should be 
named "Text".

-------------

PR Review: https://git.openjdk.org/jfx/pull/2302#pullrequestreview-5167907811
PR Review Comment: https://git.openjdk.org/jfx/pull/2302#discussion_r3979747451

Reply via email to