On Wed, 23 Sep 2026 12:28:14 GMT, Nir Lisker <[email protected]> wrote:
>> modules/javafx.base/src/main/java/javafx/beans/value/ObservableValue.java
>> line 104:
>>
>>> 102: * {@code oldValue} is equal to the value that was reported as
>>> {@code newValue}
>>> 103: * in the previous notification delivered to that listener.
>>> 104: * <li>If a change listener modifies the value in its callback,
>>> the change
>>
>> It might be clearer to say "ObservableValue" instead of "value".
>
> I think that "value" is better. The listener changes the wrapped value in the
> `ObservableValue`, not the `ObservableValue` itself.
I compromised here and said "modifies the observable's value in its callback"
-------------
PR Review Comment: https://git.openjdk.org/jfx/pull/1081#discussion_r4112127354