A few tips:

For (1), You could split your _javascript_ into separate modules in your development environment. During your
build process you can concat the relevant js files and run it through a _javascript_/css compressor like
the YUI Compressor. The compressor strips off code comments and also does a bunch of optimizations to
give a single js file that you can use for your deployment.

You can also consider generating separate js files for your profile view and canvas view, because typically
the profile view will require much less _javascript_. This will ensure that you load up faster on the user profile.

(2) will depend largely on your application itself. Use cached makeRequest if you expect duplicates and,
as Aakash mentioned, the app data store, if you just want to store small amounts of data.

Hope that helps !
Navaneeth


prafulla wrote:
Hi all,

Of late, I have started building large scale applications using
Opensocial API, and I notice that my code involves lots of makeRequest
calls and many callback functions. Using all this _javascript_ in a
single xml file might not be the best way to do it. Are there any
guidelines on :

1) how to keep the code neat and good-looking
2) ways to minimize multiple makeRequest calls

Also, I am not sure whether it is a good practice to break up my
_javascript_ into multiple smaller files. This will improve code
readability, but I am afraid that it might increase the latency
because the application now has to access more number of files. Please
provide me your suggestions and views on this.


Thank you,
Prafulla




  


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "OpenSocial Application Development" group.
To post to this group, send email to opensocial-api@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/opensocial-api?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to