Hi All
Thanks for your response!
My question is not how to enable eth1 port. I want to know how it configure one
port to lan or wan port in WR703N.
Now I think it use bridge, and i will study to get more information about
bridge in WR703N
bjzhougong
From: Aleksandr Kolesnik
Date: 2014-02-18 21:26
To: bjzhougong; OpenWrt Development List
Subject: Re: [OpenWrt-Devel] How to use ethernet port as lan or wan port in
WR703N
you need to build own image where enable eth1 port. eth1 connected to internal
switch. Read topics https://forum.openwrt.org/viewtopic.php?id=48907 and
https://forum.openwrt.org/viewtopic.php?id=48892
2014-02-18 15:04 GMT+02:00 bjzhougong <bjzhoug...@126.com>:
Thanks for All
but in WR703N's network config, it doesn't has switch:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
# option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.22.1'
option netmask '255.255.255.0'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
bjzhougong
From: camden lindsay
Date: 2014-02-18 06:23
To: OpenWrt Development List
CC: bjzhougong
Subject: Re: [OpenWrt-Devel] How to use ethernet port as lan or wan port in
WR703N
It sounds like you have to re-configure the switch, to have the port
that is currently 'wan' on the same vlan as the LAN.
see http://wiki.openwrt.org/doc/uci/network/switch
On Mon, Feb 17, 2014 at 2:04 PM, jonsm...@gmail.com <jonsm...@gmail.com> wrote:
> On Mon, Feb 17, 2014 at 4:48 PM, Hartmut Knaack <knaac...@gmx.de> wrote:
>> jonsm...@gmail.com schrieb:
>>> The switch (esw) configuration separates the LAN and WAN ports.
>> But according to the wiki, the 703n has only one ethernet port and no switch.
>
> AR9331 has the switch on chip.
> http://www.eeboard.com/wp-content/uploads/downloads/2013/08/AR9331.pdf
>
>
>>>
>>> On Mon, Feb 17, 2014 at 4:07 PM, Hartmut Knaack <knaac...@gmx.de> wrote:
>>>> bjzhougong schrieb:
>>>>> Dear Sirs.
>>>>>
>>>>>>> As we know, we can configure "network.lan.interface" or
>>>>>>> "network.wan.interface" as eth0 to use ethernet port as lan or wan port
>>>>>>> on WR703N.
>>>>>>> I think it should need to do anything in driver for switch ethernet
>>>>>>> port,
>>>>>>> and I want to know what happened between user space and kernel space
>>>>>>> after we run "/etc/init.d/network restart",
>>>>>>> Thanks for any idea about this!
>>>>> If there is any help? Thanks!
>>>> Not sure, what exactly you want to know. When running "/etc/init.d/network
>>>> restart", all the configured options in /etc/config/network get
>>>> configured. See http://wiki.openwrt.org/doc/uci/network for more
>>>> information about available options.
>>>> When changing a certain network device from WAN to LAN, it is mainly about
>>>> switching the configuration from being DHCP master or slave, and some
>>>> routing configurations.
>>>>> ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>>>>> bjzhougong
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> openwrt-devel mailing list
>>>>> openwrt-devel@lists.openwrt.org
>>>>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>>>> _______________________________________________
>>>> openwrt-devel mailing list
>>>> openwrt-devel@lists.openwrt.org
>>>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>>>
>>>
>> _______________________________________________
>> openwrt-devel mailing list
>> openwrt-devel@lists.openwrt.org
>> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
>
>
> --
> Jon Smirl
> jonsm...@gmail.com
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel@lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel