On 18.02.2019 19:00, Ilya Maximets wrote:
> Few more fixes + dummy implementation to enable unit testing
> of this feature.
> 
> One more patch with refactoring:
>       * https://patchwork.ozlabs.org/patch/996328/
> 
> Version 5:
>       * 'dp_packet_mbuf_init' --> generic 'dp_packet_init_special'
>       * 'dp_packet_offload_invalidate' --> 'dp_packet_offload_reset'

Typo,
s/dp_packet_offload_reset/dp_packet_reset_offload/

>       * Offload bitmasks turned to enum.
>       * Dropped redundant OVS_UNUSED.
>       * Added Acks from Flavio to corresponding patches.
> 
> Version 4:
>       * Rebase on current master.
> 
> Version 3:
>       * Skip tests on non-Linux systems.
> 
> Version 2:
>       * Patch #3 rebased on top of current master.
> 
> 
> Ilya Maximets (9):
>   dpif-netdev: Reduce log level for not found mark id.
>   dp-packet: Constantify offloading APIs.
>   dp-packet: Refactor offloading API.
>   dp-packet: Add flow_mark support for non-DPDK case.
>   dp-packet: Copy flow mark on packet clone.
>   netdev-dummy: Implement dummy put/del flow offload API.
>   netdev-dummy: Set flow mark for offloaded flows.
>   netdev-dummy: Add flow offloading related logs.
>   dpif-netdev.at: Add basic test for partial HW offloading.
> 
>  lib/dp-packet.c      |  19 ++--
>  lib/dp-packet.h      | 106 +++++++++++-----------
>  lib/dpif-netdev.c    |   4 +-
>  lib/netdev-dpdk.c    |   6 +-
>  lib/netdev-dummy.c   | 206 +++++++++++++++++++++++++++++++++++++++----
>  lib/netdev.c         |   4 +-
>  tests/dpif-netdev.at |  74 ++++++++++++++++
>  7 files changed, 337 insertions(+), 82 deletions(-)
> 
_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to