> -----Original Message-----
> From: Amber, Kumar <kumar.am...@intel.com>
> Sent: Tuesday, June 28, 2022 9:45 AM
> To: ovs-dev@openvswitch.org
> Cc: echau...@redhat.com; i.maxim...@ovn.org; Ferriter, Cian
> <cian.ferri...@intel.com>; Stokes, Ian <ian.sto...@intel.com>; 
> f...@sysclose.org;
> Van Haaren, Harry <harry.van.haa...@intel.com>; Amber, Kumar
> <kumar.am...@intel.com>
> Subject: [PATCH v3 3/5] dpif-netdev-avx512: Refactor avx512 dpif and create 
> new
> APIs.
> 
> Create new APIs for the avx512 DPIF, enabling one baseline
> common code to be specialized into DPIF implementations for
> "outer" processing, and "recirc" processing.
> 
> Signed-off-by: Kumar Amber <kumar.am...@intel.com>
> Signed-off-by: Cian Ferriter <cian.ferri...@intel.com>
> Co-authored-by: Cian Ferriter <cian.ferri...@intel.com>

<snip>

> diff --git a/lib/dpif-netdev-avx512.c b/lib/dpif-netdev-avx512.c
<snip>

> +static int32_t
> +dp_netdev_input_avx512__(struct dp_netdev_pmd_thread *pmd,
> +                         struct dp_packet_batch *packets,
> +                         bool md_is_valid, odp_port_t in_port);
> +

<snip>

> +static inline int32_t ALWAYS_INLINE
> +dp_netdev_input_avx512__(struct dp_netdev_pmd_thread *pmd,
> +                         struct dp_packet_batch *packets,
> +                         bool md_is_valid OVS_UNUSED, odp_port_t in_port)
>  {

Hard to see in diffs, but easier in the full file post-patch, there is 1 
function
being defined and then declared/implemented right after eachother here.
Remove the definition, its duplicate code.

_______________________________________________
dev mailing list
d...@openvswitch.org
https://mail.openvswitch.org/mailman/listinfo/ovs-dev

Reply via email to