On Tuesday 19 November 2002 11:54, Leopold Toetsch wrote:
> Daniel Grunblatt wrote:
>
> > The problem is when you want to implement an opcode like div, which is
> > easy in ppc but not in arm.... ideas?
>
> I don't know arm, but this belongs to jit_emit.h, how it's done there is
> a different issue.
>

what if we just don't want to implement that opcode in this specific 
architecture?

> But can we have a united syntax for {c,r}isc.jit. The problem currently
> is, that moves or other ops are sometimes written as op(src, dest),
> sometimes exactly the other way round.
>
> I really want this have sorted out. I'm currently writing tests
> (jit/i386 is failing a lot of them, due to wrong move directions: e.g.
> add_i_i_i, sub_i_i_i)
>
> >>Proposed naming of ops:
> >>
> >>   jit_emit_<op>_<rmi>_<in>(...)
> >>
> >>   <op> operations mov, add, sub, mul, ...
> >>   <rmi> register, memory, immediate, for all parameters
> >>        (source, dest) or (source, source, dest)
<rmid>  register, memory, immediate, displacement

>
> We could do it like parrot (dest, src, src) too, but I want really a
> unique naming convention.
>
> leo

Cool, let's do it like parrot.

I just committed a renaming for the ppc.

I believe that Parrot_end will have to call jit_emit_end() that will reside in 
jit_emit.h and will be just like Parrot_end is now since every calling 
convention is different.

Daniel Grunblatt.

Reply via email to