At 11:11 AM +0100 3/23/03, Leopold Toetsch wrote:
instead of:

   PMC* getprop (STRING* key) {
        return ((PMC *)SELF->data)->vtable->getprop(INTERP,
                (PMC *)SELF->data, key);
   }

this now is:

   PMC* getprop (STRING* key) {
        return VTABLE_1(getprop, (PMC*) SELF->data, key);
   }

While I'm all for the macros (yeah, I know, debugger stepping issues and all) I'd rather this be:


VTABLE_getprop(...

rather than

VTABLE_1(getprop,...

because the latter form doesn't give us much of a boost when put getprop behind a layer of indirection in the vtable, or something like that.
--
Dan


--------------------------------------"it's like this"-------------------
Dan Sugalski                          even samurai
[EMAIL PROTECTED]                         have teddy bears and even
                                      teddy bears get drunk

Reply via email to