I'm pondering what the proper syntax is for a subroutine parameter with both a trait and a default. That is...
sub foo ($arg = 42) and sub foo ($arg is readonly) together in one parameter. Would that be sub foo ($arg = 42 is readonly) or sub foo ($arg is readonly = 42) The first looks ambiguous, what if the trait is meant to apply to the default? The second looks downright wrong. PS Incidentally, it seems silly to have "is rw" but not "is ro". I keep writing "is ro". -- package Outer::Space; use Test::More tests => 9;