On Sat, 9 Jul 2022 at 12:24, Zhihong Yu <z...@yugabyte.com> wrote:
>
>  It seems the code would be more readable if you keep the assignment in else 
> block below:
>
> +                   else if (rte->rtekind == RTE_SUBQUERY ||
> +                            rte->rtekind == RTE_VALUES)
>                         continue;
> -                   rtename = rte->join_using_alias->aliasname;
>                 }
> -               else
> -                   rtename = rte->eref->aliasname;
>
> because rtename would be assigned in the `rte->rtekind == RTE_JOIN` case.
>

But then it would need 2 else blocks, one inside the rte->alias ==
NULL block, for when rtekind is not RTE_JOIN, RTE_SUBQUERY or
RTE_VALUES, and another after the block, for when rte->alias != NULL.
I find it more readable this way.

Regards,
Dean


Reply via email to