Peter Eisentraut <[EMAIL PROTECTED]> writes:
> I think everyone will find a mode they like here.
+1. A marginal style suggestion: if you did
var_welcome_message = GetVariable(pset.vars, "WELCOME_MESSAGE");
if (!var_welcome_message)
var_welcome_message = "";
then the subsequent tests would not need null-guards and would become
much more readable IMHO.
regards, tom lane
--
Sent via pgsql-hackers mailing list ([email protected])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers