max_wal_size
min_wal_size
[ scratches head... ] What's the functional effect of min_wal_size, exactly?
Replaces wal_keep_segments. The rename is to make the GUCs obviously
symmetrical, and to make it clear that the *meaning* of the variable has
changed.
Even better would be to replace min_wal_size with min_wal_time, which
would set a time span for the oldest WAL segment to be kept (up to
max_wal_size - 2). Hmmm. That doesn't seem that hard to implement.
Is it?
Um, what happens when honoring min_wal_time conflicts with honoring
max_wal_size?
When we get close enough to max_wal_size (we'll need a couple segments
of leeway, I think), we start recycling WAL segments even if they are
less that min_wal_time old. This is under the presumption that most
DBAs will prefer having the standby desyncrhonize to having the master
lock up due to running out of disk space. Presumably if such recycling
happens we'd also write a WARNING to the logs.
--
-- Josh Berkus
PostgreSQL Experts Inc.
http://www.pgexperts.com
--
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers