On 2014-12-22 14:14:31 -0500, Robert Haas wrote:
> On Fri, Dec 19, 2014 at 8:59 AM, Robert Haas <robertmh...@gmail.com> wrote:
> > And here is a new version.
>
> Here is another new version, with lots of bugs fixed.

A couple remarks:
* Shouldn't this provide more infrastructure to deal with the fact that
  we might get less parallel workers than we had planned for?
* I wonder if parallel contexts shouldn't be tracked via resowners
* combocid.c should error out in parallel mode, as insurance
* I doubt it's a good idea to allow heap_insert, heap_inplace_update,
  index_insert. I'm not convinced that those will be handled correct and
  relaxing restrictions is easier than adding them.
* I'd much rather separate HandleParallelMessageInterrupt() in one
  variant that just tells the machinery there's a interrupt (called from
  signal handlers) and one that actually handles them. We shouldn't even
  consider adding any new code that does allocations, errors and such in
  signal handlers. That's just a *bad* idea.
* I'm not a fan of the shm_toc stuff... Verbose and hard to read. I'd
  much rather place a struct there and be careful about not using
  pointers. That also would obliviate the need to reserve some ids.
* Doesn't the restriction in GetSerializableTransactionSnapshotInt()
  apply for repeatable read just the same?
* I'm not a fan of relying on GetComboCommandId() to restore things in
  the same order as before.
* I'd say go ahead and commit the BgworkerByOid thing
  earlier/independently. I've seen need for that a couple times.
* s/entrypints/entrypoints/

Greetings,

Andres Freund

-- 
 Andres Freund                     http://www.2ndQuadrant.com/
 PostgreSQL Development, 24x7 Support, Training & Services


-- 
Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-hackers

Reply via email to