Hi everyone, something I’ve meant to ask over the years, as I’ve seen lots of 
variation and was taught something else in the day...

What is the suggested way of naming parameters?

I was taught {“a”/“an”}DataType, so it would be:

#name: aString

Which works ok (although falls apart if you refactor as the tools don’t 
interpret it - although I guess could be improved to do so)

However often I find myself wanting to communicate a bit better as in:

#name: fullNameString

Which isn’t strictly a datatype (and I tend to leave out the a/an when I do 
this). But it feels a bit off piste and it does make me consider whether my 
selector is named badly and should be:

#fullName: aString

Which takes me back to the convention I learned long ago.

This said however, we often need to match similar #on:do, #in: generic selector 
names and then it’s not always obvious the intent of parameter.

Any thoughts to share?

I ask because for exercism, we should try and set a good example.

Tim

Sent from my iPhone

Reply via email to