apol added inline comments.

INLINE COMMENTS

> hein wrote in ItemGridDelegate.qml:33
> QVariant() evaluates to false, and not all models implement this role to 
> return `true` by default. Hence the check for an explicit false.
> 
> The alternative would be to patch all the models.

so model.enabled you want it to resolve to true? This will be hard to read to 
anyone who isn't you.

How about `model.hasOwnProperty("enabled") && model.enabled`? Or `typeof 
model.enabled === "undefined" || model.enabled`

REPOSITORY
  R119 Plasma Desktop

BRANCH
  master

REVISION DETAIL
  https://phabricator.kde.org/D20237

To: hein, #plasma, davidedmundson
Cc: apol, plasma-devel, jraleigh, GB_2, ragreen, Pitel, ZrenBot, lesliezhai, 
ali-mohamed, jensreuterberg, abetts, sebas, mart

Reply via email to