If you want to be accurate, the methods should be named

getElementByCSSSelector
getElementsByCSSSelector

and be integrated with the CSS DOM module.

There's one thing I don't understand ? Why returning a StaticNodelist ?
if I want something static I just use some xpath to get a snapshot.
CSS selectors are evaluated at runtime and are dynamic.
The NodeList should be live, else it beats the purpose of this method.


Robin Berjon <[EMAIL PROTECTED]> escreveu:


On Dec 19, 2006, at 17:51, Charles McCathieNevile wrote:
1. Does anyone see any other issue in the current draft that should be fixed? 2. For the following options, do you consider the names "fine", "not great but acceptable", or "unacceptable"?
     getElementBySelector/getElementsBySelector
     match/matchAll
     matchSelector/matchAllSelectors

I find match and matchAll to be unacceptable. In terms of genericity, usefulness, and actual deployed usage CSS comes third behind regular expressions and XPath, both of which come to mind before CSS does.

Beyond that I don't have a strong opinion but I find matchSelector/ matchAllSelectors to be better due to being shorter (and not having a zillion casing toggles like the gEBS).

If you want a name that matches usage and the reality of what us developers will understand intuitively, I would recommend matchCSS. It's short, it's obvious, and it says exactly what it does.




Reply via email to