On Mon, 20 Dec 2010 21:41:16 +0100, Tomasz Rybak <bogom...@post.pl> wrote:
> At the same time - could you look into CURAND patch I have sent
> to the list (attached here)? Last email I have sent on 2010-12-15 22:06
> I would like to finish it and then finish prefix scan.

I've taken a look at your CURAND code, here are a few comments:

- The user should not *have* to specify generator_count. Instead, we
  should supply a reasonable default based on the device's compute
  capability, as you describe in the docs.
  (Likewise, the docs don't need to be redundant.)

- I don't like the name "Randomizer". "RandomNumberGenerator" is long,
  but IMO a better name.

- What's the difference between the quasi- and non-quasi versions? It
  looks like there's a ton of duplicated code between the two. This
  should be eliminated, perhaps by inheritance or through another way.

- Tests should go in tests/test_gpuarray.py.

- Rename fill_in_* to fill_*.

Thanks for your contribution! Looking forward to your comments.

Andreas

Attachment: pgpcw0RvMcnxa.pgp
Description: PGP signature

_______________________________________________
PyCUDA mailing list
PyCUDA@tiker.net
http://lists.tiker.net/listinfo/pycuda

Reply via email to