INADA Naoki added the comment:

Antonie:

Thank you for you comment.
Actually speaking, size of instructions are reduced on amd64@gcc.

lookdict_unicode_nodummy and lookdict_split doesn't have any reason to have 
duplicated code anymore.  I'll do dedupe for them first.

lookdict and lookdict_unicode have one difference between code before loop and 
inner loop:

// before loop:
    if (ix == DKIX_DUMMY) {
        freeslot = i;

// inner loop:
        if (ix == DKIX_DUMMY) {
            if (freeslot == -1)
                freeslot = i;

Since lookdict_unicode may be used for namespace, I'll keep it for now.
But lookdict() is very unlikely to be used for namespace.  I'll dedupe it after 
checking some macro/micro benchmarks.

----------

_______________________________________
Python tracker <rep...@bugs.python.org>
<http://bugs.python.org/issue29304>
_______________________________________
_______________________________________________
Python-bugs-list mailing list
Unsubscribe: 
https://mail.python.org/mailman/options/python-bugs-list/archive%40mail-archive.com

Reply via email to