FWIW, I'm fine with making these methods on float -- a class method
float.fromhex(...) echoes e.g. dict.fromkeys(...) and
datetime.fromordinal(...). The to-hex conversion could be x.hex() --
we don't tend to use ".toxyz()" as a naming convention much in Python.

On Sun, Jun 29, 2008 at 5:26 PM, Mark Dickinson <[EMAIL PROTECTED]> wrote:
> On Sun, Jun 29, 2008 at 12:46 AM, Raymond Hettinger <[EMAIL PROTECTED]> wrote:
>> Is everyone agreed on a tohex/fromhex pair using the C99 notation as
>> recommended in 754R?
>
> Sounds good to me.
>
> I've attached a Python version of a possible implementation to the issue. See:
>
> http://bugs.python.org/file10780/hex_float.py
>
> It might be useful for testing.
>
> Mark
> _______________________________________________
> Python-Dev mailing list
> Python-Dev@python.org
> http://mail.python.org/mailman/listinfo/python-dev
> Unsubscribe: 
> http://mail.python.org/mailman/options/python-dev/guido%40python.org
>



-- 
--Guido van Rossum (home page: http://www.python.org/~guido/)
_______________________________________________
Python-Dev mailing list
Python-Dev@python.org
http://mail.python.org/mailman/listinfo/python-dev
Unsubscribe: 
http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com

Reply via email to