On Thu, Nov 11, 2010 at 8:43 AM, Fred Drake <[email protected]> wrote: .. > Since trace is documented and rx_blank isn't covered, I think it's > pretty clear it was never intended as API. I'd be fine with changing > the visibility of rx_blank, and see no need to change its name.
While I obviously agree with your conclusion, your logic is not perfect because trace documentation is *much* younger than the module. How would you apply your reasoning to trace.find_strings()? It is undocumented, its name is misleading, but it is used in the wild according to google code search. I draw the line somewhere between trace.rx_blank and trace.find_strings. _______________________________________________ Python-Dev mailing list [email protected] http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/archive%40mail-archive.com
