def run3( block ):
   for _ in range( 3 ):
      block()

run3():
   normal_suite()

Introduces new syntax; arbitrary functions can follow 'colon'.

Maintains readability, meaning is consistent.

Equivalent to:

def run3( block ):
   for _ in range( 3 ):
      block()

@run3
def anonfunc():
   normal_suite()

Simplification in cases in which decorators are use often.
-- 
http://mail.python.org/mailman/listinfo/python-list

Reply via email to