On Fri, Sep 12, 2008 at 4:09 PM, Diez B. Roggisch <[EMAIL PROTECTED]> wrote:

>
> You should also consider using PEP8 style naming.
>
>
> Diez


class FolderInUse:

    def __init__(self, core):
        self.core = core

    def true_for(self, archivefolder):
        return any([instance.forbid_to_close(archivefolder) for instance in
            self.core.active_outgoing_registration_instances()])

Is this any better? The true_for name does not satisfy me a lot...
maybe because it is too similar to True. Anyway, I'm trying a good
naming so that code is readable, like:

specification = FolderInUse(core)

if specification.true_for(folder):
   ...

Any thought about this?

Regards
Marco


-- 
Marco Bizzarri
http://notenotturne.blogspot.com/
http://iliveinpisa.blogspot.com/
--
http://mail.python.org/mailman/listinfo/python-list

Reply via email to